The following document contains the listing of user tags found in the code. Below is the summary of the occurrences per tag.
Tag Class | Total number of occurrences | Tag strings used by tag class |
---|---|---|
FIXME's | 2 | FIXME |
TODO's | 43 | TODO |
Each tag is detailed below:
Number of occurrences found in the code: 2
org.kuali.rice.kns.web.struts.action.KualiLookupAction | Line |
---|---|
any reason this is inside this "if" instead of the outer one, like above - this seems inconsistent | 304 |
org.kuali.rice.kns.web.ui.Field | Line |
this one definitely seems iffy, could be confused with regular fieldType, is there another better name or can this go away? | 110 |
Number of occurrences found in the code: 43
org.kuali.rice.kns.datadictionary.LookupDefinition | Line |
---|---|
catch exception if service locator call fails | 162 |
org.kuali.rice.kns.document.authorization.MaintenanceDocumentRestrictionsBase | Line |
next block could probably be removed since the superclass would return null for a read-only field | 52 |
org.kuali.rice.kns.inquiry.KualiInquirableImpl | Line |
generics do not match between call to module service and call to lookup service | 98 |
If this is to get a single BO, why using the lookup service? | 126 |
replace with inquiry menu bar | 461 |
org.kuali.rice.kns.kim.type.DataDictionaryTypeServiceBase | Line |
will this work for user ID attributes? | 284 |
org.kuali.rice.kns.lookup.AbstractLookupableHelperServiceImpl | Line |
why is this not using the businessObject parmeter's class? | 496 |
org.kuali.rice.kns.lookup.KualiLookupableHelperServiceImpl | Line |
Fix? - this does not handle nested properties within the EBO. | 78 |
org.kuali.rice.kns.lookup.LookupUtils | Line |
chb: that should not be the case -- the relationship object the two rely upon should be established outside of the lookup/quickfinder code | 420 |
org.kuali.rice.kns.maintenance.KualiGlobalMaintainableImpl | Line |
this needs refactoring ... its kind of lame that we have this set of compound list statements, this should all be refactored. This could be moved into a method on all GBOs, like GBO.prepareForSave(), or even better, subclass KualiGlobalMaintainableImpl for each global, since this is all maintainable-related stuff. | 63 |
remove this whole pseudo-assertion code block once this gets moved into a doc-specific maintainableImpl class. | 73 |
Revisit this. Changing since getPrimaryKeys and listPrimaryKeyFieldNames are apparently same. May be we might want to replace listPrimaryKeyFieldNames with getPrimaryKeys... Not sure. | 79 |
org.kuali.rice.kns.maintenance.KualiMaintainableImpl | Line |
rename once 'newCollectionLines' is removed | 88 |
org.kuali.rice.kns.maintenance.rules.MaintenanceDocumentRuleBase | Line |
when/if we have standard support for DO retrieval, do this check for DO's | 766 |
Good suggestion from Aaron, dont bother checking the DB, if all of the objects PK fields dont have values. If any are null or empty, then we're done. The current way wont fail, but it will make a wasteful DB call that may not be necessary, and we want to minimize these. | 772 |
should this be getting labels from the view dictionary use the DataDictionary service to translate field name into human-readable label | 812 |
org.kuali.rice.kns.service.BusinessObjectAuthorizationService | Line |
refactor for general objects | 32 |
org.kuali.rice.kns.util.FieldUtils | Line |
do we need to prefix the universalIdAttributeName in Field as well? | 921 |
assign the correct propertyName to the container in the first place. For now, I'm wary of the weird usages of constructContainerField(). | 1408 |
- Rice 2.0 - maybe need this to be smaller than the actual attribute's max length? | 1708 |
org.kuali.rice.kns.web.comparator.CellComparatorHelper | Line |
, do we really need to create so many comparators (1 per each cell)? | 98 |
org.kuali.rice.kns.web.struts.action.KualiAction | Line |
create a method for this to be used by both lookup & inquiry ? | 643 |
org.kuali.rice.kns.web.struts.action.KualiDocumentActionBase | Line |
this should be pulled into a properties file | 304 |
remove this when further testing passed if (form instanceof KualiDocumentFormBase) { UserSession userSession = (UserSession) request.getSession().getAttribute(RiceConstants.USER_SESSION_KEY); // force to recreate formkey in execute method if (document instanceof SessionDocumentService && userSession.retrieveObject(kualiDocumentFormBase.getFormKey()) != null) { userSession.removeObject(kualiDocumentFormBase.getFormKey());; } } | 551 |
remove this when further testing passed if (form instanceof KualiDocumentFormBase) { UserSession userSession = (UserSession) request.getSession().getAttribute(RiceConstants.USER_SESSION_KEY); // force to recreate formkey in execute method if (document instanceof SessionDocumentService && userSession.retrieveObject(kualiDocumentFormBase.getFormKey()) != null) { userSession.removeObject(kualiDocumentFormBase.getFormKey());; } } | 591 |
gah! this is awful | 1392 |
org.kuali.rice.kns.web.struts.action.KualiMaintenanceDocumentAction | Line |
this code should be abstracted out into a helper also is it a problem that we're not calling setGenerateDefaultValues? it blanked out the below values when I did maybe we need a new generateDefaultValues that doesn't overwrite? | 319 |
Cathy remember to delete this block of comments after I've tested. PersistableBusinessObject bo = document.getNewMaintainableObject().getBusinessObject(); Collection maintCollection = this.extractCollection(bo, collectionName); String docTypeName = ((MaintenanceDocument) maintenanceForm.getDocument()).getDocumentHeader().getWorkflowDocument().getDocumentType(); Class collectionClass = extractCollectionClass(docTypeName, collectionName); | 536 |
sort of collection, new instance should be first | 679 |
Should we keep this logic and continue using currentTabIndex as the key in the tabStates HashMap ? | 740 |
Should we keep this logic and continue using currentTabIndex as the key in the tabStates HashMap ? | 867 |
org.kuali.rice.kns.web.struts.form.KualiDocumentFormBase | Line |
we should not be referencing kew constants from this class and wedding ourselves to that workflow application This class is the base action form for all documents. | 62 |
is this still needed? I think it's obsolete now | 84 |
Chris - Notes: remove the above and change the below from boNotes when notes are finished overriding note formatter to make sure they post back the full timestamp | 155 |
rk implemented to account for caps coming from kuali user service from workflow | 573 |
org.kuali.rice.kns.web.struts.form.KualiMaintenanceForm | Line |
to be persisted in the lookup results service instead? | 90 |
org.kuali.rice.kns.web.struts.form.LookupForm | Line |
remove these once DD changes have been made | 469 |
remove these once DD changes have been made | 474 |
remove these once DD changes have been made | 479 |
remove these once DD changes have been made | 484 |
org.kuali.rice.kns.web.struts.form.pojo.PojoFormBase | Line |
see KULOWF-194 testForPojoHack(this, keypath); | 181 |
org.kuali.rice.kns.web.ui.FieldBridge | Line |
St. Ailish says review this. A question was raised on 11-16-2006 Tuscon meeting as to why this is done here and not in the formatter. | 323 |
org.kuali.rice.kns.web.ui.SectionBridge | Line |
Revisit this. Changing since getPrimaryKeys and listPrimaryKeyFieldNames are apparently same. May be we might want to replace listPrimaryKeyFieldNames with getPrimaryKeys... Not sure. | 762 |